» Today's Birthdays

None
Thanks Thanks:  0
Likes Likes:  1
Dislikes Dislikes:  0
Results 1 to 3 of 3

Thread: Belt issues

  1. #1

    Join Date
    Oct 2016
    Location
    Surprise az
    Posts
    2

    Belt issues

    I have a 2012 teryx 4 750 and have been some trouble with the belt I have been through three of them in last two months so the first one lasted 1900 miles and completely blew up which was expected. Replaced the second one in the woods and put maybe 50 miles on and blew the top half of the belt off but still moved back to camp. Replaced it again and took out for a ride today and same thing the top half of the belt is gone again with only 40 miles on it. This time I smelt the belt before it blew off don't under stand. I cleaned it really good but didn't relube anything because wasn't aware I was supposed to. Maybe time for a clutch mod kit. Plus it's is bone stock and all three belts were Kawasaki belts. Thoughts and opions please

  2. #2
    Administrator WV Hot Rod Rhino's Avatar
    Join Date
    Dec 2013
    Location
    Mount Hope, West Virginia, United States
    Posts
    8,703
    youve got something wore..send them both in and i will get them fixed up
    James Davis
    If you have questions call me!!!
    304-673-2602
    304-877-3419
    Check out our web http://www.jbshotrodperformance.com/
    Email to - jamesbodyshop@hotmail.com
    Ship to - 131 Davis Ct., Mt. Hope, WV 25880

  3. Likes Timmi liked this post
  4. #3

    2013 trx4

    I have the same issue with my 2013 first belt busted put on the second belt only drove it for about 40-50 miles and it busted again what can the problem be did you ever get yours fixed

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.1