Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5
  1. #1

    Diff lock not Locking

    My diff lock doesnt always spin both front tires????
    Anyone else run into this problem??


    Sent from my iPad using Tapatalk
    Using Tapatalk

  2. #2
    Can you hear the actuator engage from 2 wheel to 4 wheel then to lock? Does the switch LED come on in lock?

  3. #3
    scottwv's Avatar
    Join Date
    Dec 2013
    Location
    Charleston , WV
    Posts
    2,204
    If you can hear the servo motors working , try changing the diff oil . Mine was getting "sluggish" coming out of 4x4 ...changed the oil , and it started working right .
    08 700 ...

  4. #4
    cruiserheads's Avatar
    Join Date
    Dec 2013
    Location
    Calgary, AB, Canada
    Posts
    10
    When I first bought my Rhino my diff-lock was not engaging. I turned out to be a bent shift fork.
    06 Rhino 660, JBS sheave, Dynatec CDI, 27" Mud Lite XTR, and some other crap.

  5. #5
    If your led indicator is flickering or going dim you may have a shorted servo,also check the switch connections for corrosion,take out the switch first ,clean and diaelectric grease and reinstall
    AJ's SXS Accessories 304-575-0342

    For Accessories / Help and or Questions and on Facebook @ AJ'S SXS Accessories

    Website address
    www.ajswildcataccessories.com

    Facebook https://www.facebook.com/pages/AJS-SXS-Accessories/219547124736474?ref=br_tf

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •