» Today's Birthdays

wrfd77 (43)
Thanks Thanks:  0
Likes Likes:  0
Results 1 to 1 of 1
  1. #1

    Join Date
    Nov 2020
    Location
    Belton, South Carolina
    Posts
    1

    2006 Yamaha Rhino 450. Load popping on driver side of unit.

    Need help on trouble shooting my ride. Just had motor rebuild and new rear axles. Got a very loud pop coming from the front of the motor on clutch side. Machine in 2 wheel drive when this happening and has a little pulling strain on the motor. Like going up a hill or across small ditch when you get this sudden pop and you can see back wheels jump. Carry back to the mechanic that build motor and its not the motor and he confused on this sound but has not got time to check out at this moment because book up. I trying to find and fix myself because hunting season and I need my ride.. I have the clutch out and secondary out and see no problems with metal wear . Clutch is factory 2006 unit and I am going to replace everything with JBS parts when I find out what wrong. My next step is checking wet clutch and one way bearing. Then to the front drive shaft gears and check them. Need help if anyone has had this problem before to help me from replacing parts to find. I have jack the unit up and put and gear and run the engine turning the wheel and its smooth no popping. Only when it got pressure driving when you get this pop. Thanks for any help.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.1